A small feedback on the updated stylish website

Insurance is an important thing. You are completing a difficult but important mission for everyone. Thank you for your work!

The updated design looks great! It is noticeable that the team tried and succeeded in their work.
On the main page, you can add the phrase: And" the protocols continue to be hacked day by day " - to enhance the effect. I think there are already more than 15 of them. It is sad… But InsurAce will protect everyone. :slightly_smiling_face:

On the main page:
When I am on the “Get insur” tab and just want to expand the “About” list, I automatically get to the main page. I.e. the command does not expand the list as I want, but sends me to the main page.

Application:
When I buy insurance, it tells me about the restrictions. This is necessary and correct, but…


When you hover over the amount, an empty window appears.

I’m on the “Active Covers” tab. If I go to the “My Claims” tab, turn on the translator for the site, and go back to the “Active Covers” tab, it will show me that I have 0 eth.


I really liked that it automatically suggested adding tokens INSUR to the wallet. But there is a small problem.
I just tested the “claim” function and instead of the required operation, metamask again asked me to sign a transaction about adding tokens to the wallet. At the same time, I have already added them earlier.


Now if I close this window and open it again, this transaction will hang, although I clicked cancel when it asked me about re-adding the smart contract to the wallet.

The page refresh helped me. After that, metamask asked me again about the transaction and I confirmed it. When updating the page, metamask constantly asks about adding INSUR to the wallet. It’s quite intrusive.

I staked eth. And unstaked. But I don’t have an active withdrawal window


It shows me 0

It should be noted that this problem was solved by itself.

I wanted my rewards. I had to reload the page to resolve the issue, and the wallet requested the correct operation:

I can’t vote.